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Introduction 

This document provides instructions to configure Application Integration Framework (AIF) for data 
exchange using the BizTalk adapter. The document also provides a brief overview of AIF.  

AIF enables companies to integrate Microsoft Dynamics AX and communicate with external business 
processes and partners through the exchange of XML over various transport media. AIF enables both 
business-to-business and application-to-application integration scenarios. AIF provides a programming 

model, tools, and infrastructure support for XML-based integration of application functionality and data 
with Microsoft Dynamics AX. AIF enables Microsoft Dynamics AX to expose its functionality via services 
and documents based on the Windows Communication Foundation (WCF). AIF also enables Microsoft 
Dynamics AX to consume functionality exposed by external applications through Web services.  

Audience 

This white paper is designed for BizTalk developers and Microsoft Dynamics AX system administrators 
who are responsible for installing, configuring, and troubleshooting integration with external systems 
using AIF.  

Prerequisites 

To benefit from this white paper, you should have knowledge in the following areas: 

 Enterprise application integration (EAI), business-to-business (B2B) and application-to-application 
(A2A) concepts and technologies. 

 Microsoft Dynamics AX Application Integration Framework (AIF) setup and configuration. 

 Microsoft BizTalk Server 2006 R2 administration, including troubleshooting BizTalk applications. 

 BizTalk Server application development. 

 Microsoft Visual Studio 2005. 

 XML schema of the documents exchanged. 

You also need to have a test environment set up to follow the hands-on instructions. The test 
environment is covered in a later section of this document.  

 For information about configuration and maintenance of AIF, see the Server and Database 
Administration Guide. For information about AIF for software developers, see "Integrating Other 
Applications with Microsoft Dynamics AX" in the Microsoft Dynamics AX SDK Help.  

System requirements 

Before installing the Microsoft Dynamics AX BizTalk Adapter, be sure that your system meets or 
exceeds the minimum hardware and software requirements. 

http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
http://msdn.microsoft.com/en-us/library/aa877498.aspx
http://msdn.microsoft.com/en-us/library/aa877498.aspx
http://msdn.microsoft.com/en-us/library/aa877498.aspx
http://msdn.microsoft.com/en-us/library/aa496071.aspx
http://www.microsoft.com/dynamics/ax/using/2009systemrequirements.mspx
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Overview of Application Integration Framework (AIF) 

AIF provides an extensible framework that allows you to expose Microsoft Dynamics AX business logic 
or exchange data with other applications. In AIF, data is exchanged with external systems through 
business logic exposed as services. This model provides the ability to expose any X++ class as a 
service. This service can be called from X++ or from an external system. As part of this programming 
model, a set of services is included with Microsoft Dynamics AX that is based on documents such as a 

sales order or a customer.  

AIF enables the integration of Microsoft Dynamics AX through Web services, Microsoft Message 
Queuing (MSMQ), the file system (using a directory), or BizTalk Server as shown in the following 
diagram.  

Client layer

Business logic layer

Server layer

Overview of AIF components

SO
A

P

X
M

L

AIF (Microsoft Dynamics AX services)

Async adapters
Web 

services

MSMQ, 
File

IIS
ED
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AIF BizTalk 
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Application Trading partnerMainframe System

 
Figure 1. Overview of the AIF components. 

 
With Microsoft Dynamics AX 2009, AIF introduces document services, a new abstraction for 
encapsulating business logic. Document services can be consumed directly from within the Microsoft 
Dynamics AX application (X++) or be published for consumption by external service clients through 

transport adapters or WCF services.  
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The following diagram provides a high-level overview of the AIF document services classes. 

 

  

Figure 2. Flow chart describing Microsoft Dynamics AX document services. 

The document services consist of three primary components:  

1. Document service classes: In Microsoft Dynamics AX, document services enable you to 
exchange data with external systems by sending and receiving data in XML documents. These 
documents represent business objects such as a customer, a vendor, a sales order, and so on. The 
AIF document services are designed to be extensible. Developers can create their own document 

services with the AIF Document Service Wizard or customize the services that ship with Microsoft 
Dynamics AX. 

You can use the document services to enable enterprise application integration scenarios with Web 
services and a variety of transports, including the following:  

 File system  

 Microsoft Message Queuing (MSMQ)  

 BizTalk Server  

2. Axd <Document> classes (also known as Axd classes): The document service classes call 
functionality in the Axd<Document> classes. The Axd<Document> classes contain the business 
logic for modeled entities. For example, the AxdCustomer class contains the logic for creating, 
updating, and deleting customers and related information.   

3. Ax <Table> classes: The Axd<Document> classes use the Ax<Table> classes to manipulate 
data in the database. The diagram in the preceding section illustrates how the Axd<Document> 

and Ax<Table> classes interact in a document exchange.  

The Ax<Table> classes are a further abstraction of a table and encapsulate the business logic 
associated with creation and modification of records in the database table. 
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Terminology 

This section explains the concepts used in the AIF. The AIF concepts may or may not match with the 
description of similar concepts in other products such as BizTalk Server. 

Term Description 

adapter A software component that enables message exchange using a specific 
transport. In AIF, an adapter means a transport adapter.  

business document An XML data representation of an integration interaction.   

channel A named entity used to specify where and how to send and receive 

messages. A channel specifies an adapter with its associated 
configuration information and transport address. 

document services In Microsoft Dynamics AX 2009, a new services model was introduced 
in AIF. This model provides the ability to expose any class as a service 
that can be called from X++ or from an external system. 

endpoint A company or entity that participates in a business-to-business (B2B) 
or application-to-application (A2A) data exchange. An endpoint can be 
an in-house independent system, in the case of A2A.  

endpoint action policy Determines which actions are valid for a particular endpoint. An action 
is bound to an endpoint using an endpoint action policy. 

gateway queue Provides temporary storage for documents while they wait for 
processing. Inbound messages are placed in a gateway queue by an 
inbound transport adapter. Outbound messages wait in a gateway 
queue until an outbound transport adapter picks it up for sending. 

message An individual unit of data transported between endpoint locations. A 

message consists of a document plus a header containing information 
about the transfer. 

document class  An X++ class (prefixed with Axd) with methods that perform actions 
on documents. 

pipeline processor The pipeline processor enables transformations of the 
inbound/outbound XML before/after the Microsoft Dynamics AX 
document class acts on the document. Components are provided in 
the base Microsoft Dynamics AX system for data value substitution 
and XSLT document transformations. 

Web services A unit of application logic that provides data and services to other 

applications that clients invoke by using the Simple Object Access 
Protocol (SOAP) over the Hypertext Transfer Protocol (HTTP). 

Web services can perform functions ranging from simple requests to 

complicated business processes. 
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Inbound and outbound message exchange 

This section describes processing flow for inbound and outbound messages. 

Inbound message processing 

An external system sends a message through a transport adapter such as Microsoft Message Queuing 

(MSMQ), the file system, or BizTalk Server adapter. The AIF gateway receive service polls for 
messages and then brings them into the gateway queue. The AIF inbound processing service takes the 
messages from the gateway queue. Next, the business logic in the AIF document service processes 
the message and interacts with the database. The response message is then placed in the gateway 
queue. The gateway send service sends the response message using an outbound transport adapter. 
The following diagram shows a high level overview of the processing flow for an inbound message. 

 

 

Figure 3. The conceptual message path for an inbound message. 

 

Outbound message processing 

The AIF outbound processing service processes send requests using the document services and places 

the outbound messages in the gateway queue. The AIF gateway send service then reads the 
messages from the gateway queue and sends them out using a transport adapter. These transports 
adapters include Microsoft Message Queuing (MSMQ), the file system, or BizTalk Server adapter. The 
external system then receives the message from the appropriate transport. The following diagram 
shows a high level overview of the processing flow for an outbound message. 

 

Figure 4. The conceptual message path for an outbound message. 
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Synchronous and asynchronous message processing 

AIF supports both synchronous and asynchronous data exchanges. Both the synchronous and 
asynchronous data exchanges have different requirements for installation and configuration. 
Understanding the types of exchanges that are available allows you to better match the functionality 
in AIF with your data transfer and infrastructure requirements.  

Adapter-based exchange 

Document exchanges that use transport adapters in Microsoft Dynamics AX do not require the 
installation of Microsoft Internet Information Services (IIS). These include:  

 Microsoft Message Queuing (MSMQ) 

 File system 

 BizTalk Server 

MSMQ and file system transport adapters only support the asynchronous mode of data exchange. The 
BizTalk adapter supports synchronous and asynchronous modes of data exchange.  

In the synchronous mode, BizTalk bypasses the gateway queues and communicates directly with AIF. 
Messages sent to AIF bypass the gateway queues in AIF and go directly to the document services. 
Similarly, the responses from the services bypass the AIF gateway queues and go directly to BizTalk 
Server. In this mode, BizTalk sends a message to AIF and waits to receive a response. 

In the asynchronous mode, the communication between BizTalk and AIF is done through the gateway 
queues. Messages going into AIF are sent to the gateway queue in AIF. When the batch jobs run, AIF 
retrieves the messages from the gateway queue. AIF places responses to BizTalk Server in the AIF 
gateway queue. In this mode, BizTalk Server does not wait for a response from AIF. Therefore, the 
asynchronous mode requires you to set up and use correlation in BizTalk to relate a response with its 
original message.  

Web services-based exchange 

You can use Web services for synchronous document exchanges. Web services require the installation 
and configuration of IIS. The Microsoft Dynamics AX system administrator generates the Web services 
from the Microsoft Dynamics AX business logic so that developers with limited Web experience can 
easily create their own Web services.  

Performance considerations 

Deciding when to use asynchronous or synchronous processing depends on your message volume and 

particular data transfer scenarios. If you have a high volume of messages being exchanged between 
AIF and BizTalk, you may want to implement your exchanges asynchronously. Asynchronous 
exchanges provide more control (via batch jobs and other configurations) over the load placed on 
Microsoft Dynamics AX for processing documents.  Synchronous exchanges place immediate load on 

Microsoft Dynamics AX, thereby requiring more system resources. If you need an immediate response 
from a user-initiated request, you may want to use the synchronous mode. 

You need to carefully determine the workload generated by your integration activities and the 

resulting load placed on the system. The performance considerations of integration using AIF are 
beyond the scope of this document. For more information, see the Server and Database 
Administration Guide. Microsoft Dynamics AX 2009 introduces a new batch framework. The batch 
framework has been significantly enhanced to provide a truly asynchronous (non-interactive) server-
based batch processing environment that is also capable of processing multiple tasks within a job 
across multiple Application Object Server (AOS) instances. The Microsoft Dynamics AX 2009 batch 
framework provides the capability of server-bound batches without the need for an interactive client. 

You can configure your AIF document exchange to take advantage of the parallelism offered by this 

http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
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new batch framework. For more information on the batch framework, see the Microsoft Dynamics 
AX 2009 Implementation Guide. For more information about configuration of batch jobs and parallel 
processing of inbound messages, see Server and Database Administration Guide. 

This document details how to set up and configure the AIF BizTalk adapter for data exchange. For 

more information on set up and configuration of MSMQ, file system, and Web services, see 
―Configuring document exchanges with adapters‖ topic in the Server and Database Administration 
Guide.   

Scenario Walkthrough 

This section details the document exchange between AIF and BizTalk Server using a synchronous 
mode and an asynchronous mode. The walkthrough covers two scenarios: creating a sales order in 
AIF based on an XML document from BizTalk Server and sending a purchase order from AIF to BizTalk.  

The following actions occur when you send an XML document from BizTalk to AIF to create a sales 
order. 

1. To represent another system, application or partner providing new sales, you place a sales order 
in an inbound file folder. In general, the format of this sales order can be EDI or another non-AIF 
format; for the purpose of this scenario it is an AIF sales order (XML).  This is a manual step in the 
walkthrough. However, you may have an automated process placing the sales order in the 
production environment. For more information on AIF messages and actions, see AIF messages 
topic on MSDN. 

2. BizTalk Server monitors the file folder and sends the sales order to AIF. In synchronous mode, 

BizTalk Server will bypass the AIF gateway queues and go directly to the AIF document services. 
In asynchronous mode, BizTalk Server will communicate with the AIF gateway queues.  

3. The Dynamics AX application processes the sales order and returns an entity key (sales order 
number) to BizTalk. The BizTalk application then sends the entity key to the outbound file folder. 

4. You test the sales order to confirm valid test results.  

The following actions occur when you send a purchase order from AIF to BizTalk Server.  

1. You post an open purchase order and then choose the option to send the purchase order 
electronically. 

2. AIF sends the purchase order to BizTalk Server. BizTalk Server places the purchase order in the 
file folder that you configured as the output folder. 

3. You test the purchase order to confirm valid results. 

The next sections of this white paper provide step-by-step instructions and code to configure and test 
the document exchange. You can use this walkthrough to develop an understanding of how different 

components interact in this process and test the results of the exchange. The objective of this 
document is limited to providing a hands-on experience with configuring the data exchange using the 
BizTalk adapter.  

  

http://go.microsoft.com/fwlink/?LinkId=124789
http://go.microsoft.com/fwlink/?LinkId=124789
http://go.microsoft.com/fwlink/?LinkId=124789
http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
http://msdn.microsoft.com/en-us/library/aa627117.aspx
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Before you begin 

Consider the following points before you begin:  

 The test environment: This walkthrough uses the Dynamics AX 2009 Pre-sales Demonstration 
Toolkit that is available for download at PartnerSource. PartnerSource is a secure portal that is 
available to partners who focus on Microsoft Dynamics and related business products. This Pre-
sales Demonstration Toolkit includes two Virtual PC images. The first image, VPC 1, uses a server 
name of AX-SRV-01 and the second image, VPC 2, uses a server name of AX-SRV-03. This 
walkthrough uses VPC 2. However, in order for you to follow the instructions in the walkthrough, 

you need to download and install VPC 1 and VPC 2 or have a similar test environment set up.  

Note: If VPC 2 prompts you to reinstall Visual Studio, you will need to reinstall Visual Studio 2005 

Professional edition on the image.  

 Setting up your own test environment: If you create your own test environment for this 

walkthrough, it should include the following components. For installation instructions, see the 
Microsoft Dynamics AX Installation Guide. 

 Microsoft Dynamics AX 2009 base components with Application Integration Framework (AIF). 

 Microsoft BizTalk Server 2006 R2, Standard or Enterprise edition.  

 Microsoft Visual Studio 2005 Professional edition. 

 AIF BizTalk adapter installed on the BizTalk Server host. 

 Assumption: All the references to folder path and program navigation are based on the test 
environment set up in VPC 2.  

 Login ID: You need to know the login ID for various services, steps, or users. In some cases, you 
will also need to know the password. The test environment uses contoso\administrator as the 
user ID for all of the following steps or services. The services or steps listed below are explained in 
later sections. 

 The domain administrator account and password. 

 The domain account and password used for the Business Connector proxy account. 

 The domain account used for Dynamics AX Object Server and BizTalk services. 

 The domain account and password for the Admin user in the Dynamics AX 2009 application.  

Note: Using the same account for various services and users is a deviation from security best 
practices and is done for ease of learning and troubleshooting. In a production environment, follow 
the documented best practices for Microsoft Dynamics AX, BizTalk Server, and Visual Studio. 

 Navigation in Windows: Navigation to frequently mentioned tools and programs is as follows:  

 BizTalk Server 2006 administration console: Start > All Programs > Microsoft BizTalk 
Server 2006 > BizTalk Server Administration. 

 Microsoft Dynamics AX 2009 configuration: Start > Administrative Tools > Microsoft 

Dynamics AX 2009 Configuration. 

 Microsoft Dynamics AX 2009 server configuration: Start > Administrative Tools > 
Microsoft Dynamics AX 2009 Server Configuration. 

 Viewing and managing services: Start > Administrative Tools > Services. 

 Event Viewer: Start > Administrative Tools > Event Viewer.  

 Microsoft Dynamics AX 2009 client: Start > All Programs > Microsoft Dynamics AX 2009 
> Microsoft Dynamics AX 2009. 

 Navigation in the Microsoft Dynamics AX client: Navigation to frequently mentioned tools and 
forms is as follows:  

https://mbs.microsoft.com/partnersource/deployment/documentation/howtoarticles/presalesdemokitmdax2009.htm
http://go.microsoft.com/fwlink/?LinkID=99623
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 AIF configuration: Basic > Setup > Application Integration Framework. 

 AIF queue manager, exceptions, or document history: Basic > Periodic > Application 
Integration Framework. 

 Batch jobs and tasks: Basic > Inquiries > Batch job. 

 Sales order: Accounts receivable > Common Forms > Sales Order Details. 

 Purchase order: Accounts payable > Places > Purchase Orders. 

Step-by-step instructions  

You need to complete a number of tasks for successful processing and testing of document exchange 

using the AIF adapter. This walkthrough provides step-by-step instructions for the following tasks in 
the following sections. 

 Check prerequisites for the Microsoft Dynamics AX application 

 Set up the Business Connector proxy 

 Install the AIF BizTalk adapter 

 Set up AIF configuration for the BizTalk adapter 

 Build and deploy the Visual Studio project 

 Configure orchestration in BizTalk Server 

 Configure AIF batch job and tasks 

 Test the asynchronous orchestration 

 Test the synchronous orchestration 

 Test the orchestration to send purchase orders 

 Troubleshooting 

Check prerequisites for the Microsoft Dynamics AX 
application 

The following prerequisites must be in place before undertaking the procedures in this white paper. 
For more information and step-by-step instructions, see the Microsoft Dynamics AX Installation Guide. 

1. You must have Microsoft Dynamics AX deployed and configured with the base and AIF 

components. A base system includes a database, Application Object Server (AOS), application 
files, and at least one client. The AOS server with AIF installed is referred to here as the 
application integration server.  

2. You require a Microsoft Active Directory directory service configured in native mode. You will need 
a domain account for the Business Connector proxy.  

3. Set up the Business Connector proxy.  

  

http://go.microsoft.com/fwlink/?LinkID=99623
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Set up the Business Connector proxy 

The Business Connector proxy is a Microsoft Windows domain account used by external applications to 
connect to Microsoft Dynamics AX. The Business Connector proxy provides the ―act-on-behalf-of‖ 
functionality for external user connections. The Business Connector proxy account should not be set 
up as a Microsoft Dynamics AX user account. If you have already set up the Business Connector proxy 
account, you do not need to set it up again. 

Use the following steps to set up a Business Connector proxy: 

1. Have the domain administrator create a unique user in Active Directory using the format 
domain\username. This domain account should have the following characteristics: 

 The user cannot have the same name as an existing Microsoft Dynamics AX user. 

 The password does not expire. 

 No interactive logon rights are granted. 

2. Associate the proxy account with Business Connector in Microsoft Dynamics AX. This step adds the 

proxy account to the Microsoft Dynamics AX database. Storing the proxy account in the database 
ensures that multiple AOS instances can use the same proxy account. 

3. Launch the Microsoft Dynamics AX Windows client.  

4. Launch the System service accounts form (Administration > Setup > Security > System 
service accounts).  

5. In the Business Connector Proxy group, enter values  for the following fields: 

 Set Alias = Administrator. 

 Set Network domain = contoso.com. 

6. Click OK to save and close the form. 

Install the AIF BizTalk adapter 

Prerequisites: The server where you install the AIF BizTalk adapter is called the application 
integration gateway.  The application integration gateway must have Microsoft BizTalk Server 2006 R2 
installed and configured before you install the AIF BizTalk adapter. Although not a prerequisite for 
installing the AIF BizTalk adapter, you will need Visual Studio 2005 to create a BizTalk application. You 
can install BizTalk Server and Visual Studio on the Application Object Server (AOS) server for 
development purposes. We recommend that you install BizTalk Server on a dedicated server in the 

production environment for improved performance. Ensure that you are logged on with an account 
that is a member of the Administrators group on the computer on which you are running the setup. 
For more information, see the Microsoft Dynamics AX Installation Guide. 

Use the following steps to install the AIF BizTalk adapter. 

1. Launch the Microsoft Dynamics AX 2009 Setup program.  

2. Step through the initial wizard pages. 

3. On the Modify Microsoft Dynamics AX installation page, select Add or Modify components.  
Click Next.  

4. On the Add or modify components page, select BizTalk Adapter. Click Next.  

Note: These components are already installed on VPC 2. Therefore, if you are using VPC 2, your 
options for the .NET Business Connector and BizTalk adapter will appear disabled.  

5. Click Install. 

6. Click Finish when the installation is done. 

http://go.microsoft.com/fwlink/?LinkID=99623
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7. Now make sure that the AIF BizTalk adapter has been installed and configured successfully. 

8. Launch the BizTalk Server 2006 administration console (Start > All Programs > Microsoft 
BizTalk Server 2006 > BizTalk Server Administration). 

1. In the navigation tree in the left pane, expand BizTalk Server 2006 Administration > BizTalk 

Group > Platform Settings. Click Adapters.  

2. In the right pane, confirm that the Microsoft Dynamics AX 2009 appears in the Adapters 
list and the value of the Is Configured field is Yes, as shown in the following screen shot. 

Set up AIF configuration for the BizTalk adapter 

This section provides step-by-step instruction for configuration of AIF for the BizTalk adapter.  

Configure transport adapters 

1. Launch the Microsoft Dynamics AX client. 

2. Click Basic > Setup > Application Integration Framework > Transport adapters. 

3. Under the File menu, click New to create a new record.  

4. In the Adapter class field, either select AifBizTalkAdapter from the list or enter 
AifBizTalkAdapter. This form scans for transport adapter class and presents you with a list. The 
scanning process will take some time.  

5. Check the Active box, as shown in the screen shot.  
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6. Save and close the form. 

Configure channels 

1. Click Basic > Setup > Application Integration Framework > Channels.  

2. Under the File menu, click New to create a new record.  

3. Enter values  for the following fields: 

 Set Channel ID = BTS. 

 Set Name = BTS. 

 Set Adapter = BizTalk Adapter (from the list). 

 Direction defaults to Both, and you cannot change this value.  

 Set Address = BTSG. The address field can contain any value and usually contains the name 
of your BizTalk group when you are using the BizTalk adapter. Using the name of your BizTalk 
group does not restrict access to servers in that group.  Rather, it is for convenience of 
association. You can launch the BizTalk Server 2006 Administration Console to find the name 
of your BizTalk group.  

 Set Active = Checked. 

Note: Parallel processing is beyond the scope of this document. For information on parallel 

processing, see Server and Database Administration Guide. 

 

 

  

http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
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4. Save the form and then click Configure button. This will launch the BizTalk Adapter 
configuration form as shown. 

5. The BizTalk Adapter configuration form requires the name of the host where BizTalk Server is 
installed. Every BizTalk Server instance that will connect to this channel, including production 
servers and desktop development machines, must be listed on this form. Microsoft Dynamics AX 
will allow connections to this channel only from BizTalk Server instances that are listed here. 
These BizTalk Server instances do not have to be configured in the same BizTalk Server group.  
Enter AX-SRV-03 in the Server Name field.  

6. Save and close the BizTalk Adapter configuration form. 

7. Save and close the Channels form. 
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Configure services 

1. Click Basic > Setup > Application Integration Framework > Services. 

2. Navigate to SalesSalesOrderService and check the Enabled field. If the service is already 

enabled, do nothing. This form does not have any services when opened for the first time in a new 
installation. In that case, click the Refresh button to list all the existing services, as shown. 

3. Save and close the form. 

Configure local endpoints 

1. Click Basic > Setup > Application Integration Framework > Local endpoints. 

2. Create a new record. 

3. Enter values  for the following fields, as shown in the following screen shot: 

 Set Company = CEU (from the list). 

 Set Local endpoint = LocalEP. 

 

4. Save and close the form. 
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Configure endpoints 

1. Click Basic > Setup > Application Integration Framework > Endpoints. 

2. Create a new record.  

3. Enter values for the following fields: 

 Set Endpoint ID = RemoteEP. 

 Set Name = RemoteEP. 

4. Click the Constraints tab and check No Constraints. This setting is fine for the walkthrough, but 
you need to carefully consider and apply constraints for production environments.  

5. Click the Overview tab and check the Active field as shown.  

 

6. Click the General tab. In the Local Endpoint ID field, select LocalEP from the list. In the 
Outbound channel ID field, select BTS from the list. Check the Propagate errors field, if you 

need to propagate detailed exception information to BizTalk Server.  
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7. On the Users tab, create a new record.  

1. Enter values  for the following fields: 

 Set User Type = User (from the list). 

 Set Application user or group = Admin (from the list). 

Note: This record represents the login identity for the AIF adapter on whose behalf actions will 
be taken.  In a real-world implementation, you should not use the Admin user. 

2. Save the form.  Click Action policies button as shown. This will launch the Endpoint Action 
Policies form. 

8. On the Endpoint Action Policies form: 

1. Insert a new record and enter values  for the following fields: 

 Set Action ID = SalesSalesOrderService.create (from the list). 

 Set Status = Enabled (from the list). 

2. Save the form.  

Note: You must save the form before you can continue with the next step. 

3. Click Data policies button to launch the Parameter Data Policies form. 
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4. On the Parameter Data Policies form, click the Data policies button. 

 

5. On the Endpoint action data policies form, click Set button and then click Enable all. This 
action will enable all the fields on this form. Optionally, you can click the Required column 
heading to sort the fields and see all the required fields. You need to understand the schema 
of the document that you are exchanging. 
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9. This step enables the purchase requisition service that is used to read the selected purchase order 

that is then sent electronically from Microsoft Dynamics AX to an external system.  

1. On the Endpoint form, click the Overview tab. Select RemoteEP and click Action policies.  

 

 

 

 

 

 

 

 

 

 

 

 

 

2. On the Endpoint Action Policies form, insert a new record and enter values  for the 
following fields: 

 Set Action ID = PurchPurchReqService.read (from the list). 

 Set Status = Enabled (from the list). 

3. Save the form.  

Note: You must save the form before you can continue with the next step. 

4. Click the Data policies button. This will launch the Parameter Data Policies form. 
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5. On the Parameter Data Policies form, click the Data policies button. This will launch the 
Endpoint action data policies form. 

6. On the Endpoint action data policies form, click the Set button and then click Enable all. 
This action will enable all the fields on this form. Optionally, you can click the Required 
column heading to sort the fields and see all the required fields. You need to understand the 
schema of the document that you are exchanging. 

 

10. Save and close all forms. 
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Build and deploy the Visual Studio project 

This section provides step-by-step instructions to create and deploy a Visual Studio project for 
creating the orchestrations for data exchange using synchronous and asynchronous modes.  

Create a BizTalk project and add references 

Launch Microsoft Visual Studio 2005. Create a new BizTalk project as shown in the following steps: 

1. Click File > New > Project … to launch the New Project window. 

2. Select Empty BizTalk Server Project. 

3. Enter values  for the following fields: 

 Set Name = DocProject. 

 Set Location = Desktop \ DocProject. 

 The New Project window should look like the screenshot below. 

4. Click OK. 
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Create a sales order in asynchronous mode 

This section provides step-by-step instructions to create and configure the orchestration for the 
creation of a sales order in asynchronous mode.  

Add the adapter metadata 

1. Right-click DocProject in the Solution Explorer pane and select Add > Add Generated Items. 
Select Add Adapter Metadata and click Add button. 

 

2. When the Add Adapter Wizard opens, select Microsoft Dynamics AX 2009.  Enter these field 
values:  

 Set SQL Server = AX-SRV-03. 

 Set Database = BizTalkMgmtDb. 

3. Click Next. 
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4. In the BizTalk Adapter for Microsoft Dynamics AX Schema Import Wizard, enter values for 
Server Name and TCP/IP Port.  The server name refers to the Application Object Server (AOS) 
and the port refers to the port being used by the AOS. The port is usually set to 2712. You can 
look at the Microsoft Dynamics AX 2009 Server Configuration utility to obtain the server name and 

TCP/IP port. For more information, see the Server and Database Administration Guide. 

1. For this walkthrough, enter the following values: 

 Set Server name = AX-SRV-03. 

 Set TCP/IP Port = 2712. 

2. Click Next. 

5. Expand SalesOrderService and check create: sync, create: async request, and create: 

async response as shown in the following screen shot. (When implementing a synchronous 
interchange with AIF later in this document, we will use the create: sync operation.) 

6. Click Finish. 

http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
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7. In the Solution Explorer pane, right-click the References node, select Add references and 
then click the Browse tab.  Add Microsoft.Dynamics.BizTalk.Adapter.Schemas.dll from C:\ 
Program Files\Microsoft Dynamics AX\50\Client\ Bin.  

Rename the orchestration 

Rename the orchestration to provide a meaningful name for the orchestration as shown in the 
following steps. 

1. In the Solution Explorer pane, right-click BizTalk Orchestration.odx, and rename it to 
Async.odx.  

2. Double-click Async.odx. Select Orchestration View window. Right-click Orchestration 
Properties. 
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3. Select the Properties tab. In the Typename field, enter Async. 

 

4. The Solution Explorer should now look similar to the following screenshot. 
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Add shapes to the orchestration. 

In this section, we will add shapes to the orchestration. 

 
1. Open Async.odx. You can double-click Async.odx in the Solution Explorer pane to open it. 

Using the Toolbox, add the following shapes: 

1. Receive  

2. Message Assignment  

3. Send  

4. Receive  

5. Message Assignment 

6. Send 
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2. Select Orchestration View.  Expand Types > Multi-part Message Types > 
SalesOrderService_create_Response. Right-click ReturnValue and select Properties 
Window. 

1. In the Properties window, click the Type field.  Expand Schemas, then select <Select from 

Referenced Assembly…> from the list. 

2. On the Select Artifact Type window, select EntityKeyList from Dynamics.Ax5 as shown in 
the following screen shot. 

Create messages and set properties 

1. In this section, you will create four messages and set their properties. Click Orchestration View 
tab. Right-click Messages and click New Message.  

2. Right-click Message_1, the newly created message, and select Properties Window. 

3. Set the properties for this message as follows: 

 Set Identifier = Message_AsyncIn. 

 To set MessageType, expand Schemas, then select 
DocProject.SalesOrderService_SalesOrder from the list. 

4. In Orchestration View, create the second message and set the properties for this message as 
follows:  
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 Set Identifier = Message_AsyncBtsToDyn. 

 To set MessageType, expand Multi-part message Types, then select 
DocProject.SalesOrderService_create_Request from the list.  

5. Create the third message. Set the property values as follows:  

 Set Identifier = Message_AsyncDynToBts. 

 To set MessageType, expand Multi-part Message Types, then select <Select from 
referenced assembly…> from the list. Select 
DocProject.SalesOrderService_create_Response from the list. 

6. Create the fourth message. Set the property values as follows: 

 Set Identifier = Message_AsyncOut. 

 To set MessageType, expand Schemas, then select <Select from referenced 

assembly…> from the list. Expand Microsoft.Dynamics.Biztalk.Adapter.Schema and 
select DynamicsAx5.  Select EntityKeyList as shown in the following screen shot. 
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Create correlation sets and correlation type 

This section provides step-by-step instructions for creating correlation sets and correlation type. AIF 
uses the AIF outbound gateway queue to send responses to BizTalk Server. These messages are sent 

asynchronously. Therefore, you must use correlation in BizTalk Server to relate a response to its 
original message.  

 
Note: you need the correlation sets only for the asynchronous orchestration.  

 
1. In the Orchestration View pane, right-click Correlation Sets, then select New Correlation 

Set. Set properties for Correlation_1 as follows: 

 Set Identifier = Correlation_MessageID. 

 Set Correlation Type = <Create new Correlation Type> (from the list). 
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2. Your Orchestration View will now look similar to the following screenshot.  
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3. Expand Types, then Correlation Types.  Right-click CorrelationType_1 and click Properties 
Window.  

1. Set the properties as shown in the following steps.  

 Set Identifier = CorrelationType_MessageID. 

 In the Correlation Properties field, click ellipses. In the Correlation Properties 
window, expand DynamicsAX5. Select RequestMessageId and click Add button. Your 
screen should look similar to the following screen shot. AIF sets the RequestMessageId 
property in a response message to the value of the original MessageId in the inbound 
request message.  As a MessageID is a globally unique identifier (GUID), the 
RequestMessageId alone makes a unique correlation property for asynchronous 
processing. 

2. Click OK. 

Configure shapes 

This section provides instructions to configure the shapes in the orchestration.  

1. Select Orchestration View. 

2. Right-click the shape Receive_1 and select Properties Window. Set property values as follows: 

 Set Activate = True. 

 Set Message = Message_AsyncIn. 

3. Right-click the shape ConstructMessage_1 and set properties as follows: 

 Messages Constructed = Message_AsyncBtsToDyn. You need to set this value before 
using the code in the next step to a avoid syntax error in the code.  

 Double-click MessageAssignment_1 within shape ConstructMessage_1. Copy or type the 

following code into the BizTalk Expression Editor. Note that the code makes references to 
the local and remote endpoints. We created these endpoints earlier using the AIF configuration 
forms in the Microsoft Dynamics AX application. Make sure the same values entered in the 
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code are also entered on the AIF configuration forms. In this case, we have already used the 
AIF configuration forms to create a local endpoint called LocalEP and a remote endpoint called 
RemoteEP. You do not need the following code if the XML message contains a header with the 
required information.  

Message_AsyncBtsToDyn._salesSalesOrder = Message_AsyncIn; 

Message_AsyncBtsToDyn(DynamicsAx5.DestinationEndpoint) = "LocalEP"; 

Message_AsyncBtsToDyn(DynamicsAx5.SourceEndpoint) = "RemoteEP"; 

Message_AsyncBtsToDyn(DynamicsAx5.Action) = 

"http://schemas.microsoft.com/dynamics/2008/01/services/SalesOrderService/create"; 

Message_AsyncBtsToDyn(DynamicsAx5.MessageId) = System.String.Format("{0:B}", 

System.Guid.NewGuid()); 

//  The following line provides the ability to correlate the response message from AIF. 

//  AIF uses the inbound MessageId as the outbound RequestMessageId in the response. 

Message_AsyncBtsToDyn(DynamicsAx5.RequestMessageId) = 

Message_AsyncBtsToDyn(DynamicsAx5.MessageId); 

4. Set property values of shape Send_1 as follows: 

 Set Message = Message_AsyncBtsToDyn. 

 Set Initializing Correlation Sets = Correlation_MessageID 

5. Set property values of shape Receive_2 as follows: 

 Set Message = Message_AsyncDynToBts. 

 Set Following  Correlation Sets = Correlation_MessageID. 

6. Set property values of shape ConstructMessage_2 as follows: 

1. Set Messages Constructed  = Message_AsyncOut. 

2. Double-click MessageAssignment_2 within the ConstructMessage_2 shape. Copy or type 
the following code into the BizTalk Expression Editor. 

Message_AsyncOut = Message_AsyncDynToBts.ReturnValue; 

7. Set property values of shape Send_2 as follows: 

 Set Message = Message_AsyncOut. 
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Configure operations for the shapes 

In this section, we will configure operations for the shapes in our orchestration.  

Configure operations for shape Receive_1 

1. Click the exclamation icon on shape Receive_1. Click the dialog box to create a new port. 

 
2. Click Next. 
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3. In the field, enter Port_AsyncXmlIn. Click Next. 

 
4. Set the properties as follows and then click Next: 

1. Set Port Type Name = PortType_AsyncXmlIn. 

2. Make sure all the radio buttons default to the same settings as shown in the following screen 
shot. 
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5. On the following wizard page, leave the Port binding set to ―Specify later.‖  The wizard will 
automatically set the binding when it connects the receive shape to this new port.  Click Next. 

 
6. Click Finish. 

 

7. At this message, click OK. 
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8. Port and shape connection should look like the following screen shot. 

 

Configure operations for shape Send_1 

1. Click the exclamation icon on shape Send_1. Click the dialog box to create a new port.  

 
2. In the Port Configuration Wizard, click Next. 
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3. Set Name to Port_AsyncBtsToDyn and click Next. 

 
4. Set the property values as follows and then click Next. 

 Select Use an Existing Port Type.  

 Select SalesOrderService_AsyncRequest. 
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5. Click Next. 

 
6. Click Finish. 

 

7. At this message, click OK.  
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8. Port and shape connection should look like the following screen shot.  

Set Operations for shape Receive_2 

1. Click the exclamation icon on shape Receive_2. Click the dialog box to create a new port. 

 

2. In the Port Configuration Wizard, click Next. 
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3. Set the Name to Port_AsyncDynToBts. Click Next. 

 

4. Set the following property values and then click Next. 

 Select Use an Existing Port Type. 

 Select SalesOrderService_AsyncResponse.  
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5. Click Next. 

 
6. Click Finish. 

 

7. At this message, click OK. 
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8. The port and share connection should look like the following screen shot. 

Set operations for shape Send_2 

1. Click the exclamation icon on shape Send_2. Click the dialog box to create a new port.  

 
2. Click Next. 
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3. Set the Name to Port_AsyncXmlOut and click Next. 

4. Set the property values as follows and then click Next. 

1. Select Create a new Port Type. 

2. Port Type Name = PortType_AsyncXmlOut. 
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5. Click Next. 

 
6. Click Finish. 
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7. At this message, click OK. 

 

8. The port and shape connection should look like the following screen shot. 

 

9. Save the orchestration at this point.  
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Create a sales order in synchronous mode 

This section provides step-by-step instructions to add an orchestration to create a sales order in 
synchronous mode. These procedures assume that you have already completed the instructions in the 
preceding section to create a project called DocProject. 

Add a BizTalk orchestration 

Right-click DocProject In the Solution Explorer pane and select Add > New Item > BizTalk 
Orchestration. Set the Name to Sync.odx. Click Add. 
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Add shapes to the orchestration. 

Open Sync.odx. Using the Toolbox, add the following shapes. 

1. Receive Shape 

2. Message Assignment 

3. Send Shape 

4. Receive Shape 

5. Message Assignment 

6. Send Shape 
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Create messages and set properties 

In this section, you will create four messages and set their properties. You can refer to the diagrams 
of screen shots in the preceding section for visual navigation. 

1. Click Orchestration View tab. Right-click Messages and select New Message. Set the message 
properties as follows: 

 Set Identifier = Message_SyncIn. 

 To set MessageType, expand Schemas, then select 
DocProject.SalesOrderService_SalesOrder from the list. 

2. Create the second message and set properties as follows: 

 Identifier = Message_SyncBtsToDyn. 

 To set Message Type, expand Multi- part Message Types, then select DocProject. 
SalesOrderService_create_Request from the list. 

3. Create the third message and set properties as follows: 

 Identifier = Message_SyncDynToBts. 

 To set Message Type, expand Multi-part Message Types, then select 
DocProject.SalesOrderService_create_Response from the list. 

4. Create the fourth message and set properties as follows: 

 Set Identifier = Message_SyncOut. 

 To set Message Type, expand Schemas, then select <Select from referenced 
assembly…>. In the Select Artifact Type window, expand 
Microsoft.Dynamics.Biztalk.Adapter.Schemas and select DynamicsAx5. Select 
EntityKeyList.  

Configure shapes 

This section provides instructions to configure the shapes that we added earlier to the orchestration. 
You can refer to the diagrams of screen shots in the preceding section for visual navigation. 

1. Click shape Receive_1 and set properties as follows: 

 Set Activate = True(from the list). 

 Set Message = Message_SyncIn. 

2. Click shape ConstructMessage_1  and set properties as follows: 

1. Set Messages Constructed, Message_SyncBtsToDyn (from the list). Make sure you set this 
property before using the code in the next step to avoid getting syntax errors.  

2. Double-click MessageAssignment_1 within the shape and copy or type the following code 
into the BizTalk Expression Editor. 

Message_SyncBtsToDyn._salesSalesOrder = Message_SyncIn; 

Message_SyncBtsToDyn(DynamicsAx5.DestinationEndpoint) = "LocalEP"; 

Message_SyncBtsToDyn(DynamicsAx5.SourceEndpoint) = "RemoteEP"; 

Message_SyncBtsToDyn(DynamicsAx5.Action) = 

"http://schemas.microsoft.com/dynamics/2008/01/services/SalesOrderService/create"; 

Message_SyncBtsToDyn(DynamicsAx5.MessageId) = System.String.Format("{0:B}", 

System.Guid.NewGuid()); 

3. Click shape Send_1 and set properties as follows: 

 Set Message = Message_SyncBtsToDyn. 

4. Click shape Receive_2 and set properties as follows: 
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 Set Message = Message_SyncDynToBts. 

5. Click shape ConstructMessage_2 and set properties as follows: 

1. Set Messages Constructed = Message_SyncOut. 

2. Double-click MessageAssignment_2 within the shape and type or copy the following code 

into the BizTalk Expression Editor: 

Message_SyncOut = Message_SyncDynToBts.ReturnValue; 

6. Click shape Send_2 and set properties as follows: 

 Set Message = Message_SyncOut. 

Configure operations for the shapes 

In this section, we will configure operations for the shapes in our orchestration. This section only 

provides relevant diagrams of screen shots. You can refer to the diagrams of screen shots in the 
preceding section for detailed visual navigation. 

Configure operations for shape Receive_1 

1. Click the exclamation icon on the shape Receive_1. Click the dialog box to create a new port.  

2. Click Next in the Welcome to the Port Configuration Wizard window.  

3. Set Name = Port_SyncXmlIn, and click Next. 
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4. Select Create a New Port Type. Set the Port Type Name to PortyType_SyncXmlIn. Click Next. 

 

5. On the following wizard page, leave the Port binding set to  Specify later.  The wizard will 
automatically set the binding when it connects the receive shape to this new port.  Click Next.  
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6. Click Finish 

 

7. At this message, click OK. 

 
8. Port and shape relationship should look like the following screen shot.  
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Configure operations for shape Send_1 

1. Click the exclamation icon for shape Send_1. Click the dialog box to create a new port.  

2. Click Next in the Welcome to the Port Configuration Wizard window.  

3. Set the Name to Port_Sync as shown in the following screen shot and click Next. 

 

4. In the Select a Port Type window:  

1. Select Use an Existing Port Type. 

2. Select SalesOrderService_Sync. 

3. Click Next. 
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5. Click Next. 

 

6. Click Finish. 

 

7. At this message, click OK. 
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8. Port and shape relationship should look like the following screen shot. 

 

Configure operations for shape Receive_2 

1. Connect Receive_2 shape with Port_Sync by dragging the arrow in Visual Studio. 
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2. Your orchestration should look like the following screen shot.  

 

Configure operations for shape Send_2 

1. Set operations for shape Send_2.  

2. Click the exclamation icon for shape Send_2. Click the dialog box to create a new port.  

3. Click Next in the Welcome to the Port Configuration Wizard window. 

4. Set Name to Port_SyncXmlOut in the Port Properties window and click Next.  
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5. In the Select a Port Type window: 

1. Select Create a new Port Type. 

2. Set Port Type Name to PortType_SyncXmlOut. 

3. Click Next. 

 

6. Click Next.  
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7. Click Finish. 

 

8. At this message, click OK. 

 

9. Port and shape relationship should look like the following screen shot.  

 

10. Save the project. 



 

 

61 
 

CONFIGURING THE APPLICATION INTEGRATION FRAMEWORK (AIF) BIZTALK ADAPTER FOR DATA EXCHANGE 
 

Send a purchase order from AIF 

This section provides step-by-step instructions to add an orchestration to send a purchase order from 
AIF to BizTalk Server in an asynchronous mode. This is a one way send from the AIF to BizTalk 
Server. Therefore, this asynchronous orchestration does not use a correlation set.  

Add the adapter metadata 

In this section, we will add an orchestration to the project. This step assumes that you have already 
completed the instructions in the preceding section to create a project called DocProject.  

1. Right-click DocProject in the Solution Explorer pane and select Add > Add Generated Items. 
Select Add Adapter Metadata and click Add button. 

 

2. Select Microsoft Dynamics AX 2009.  Confirm the values for the following fields and click Next. 

 Set SQL Server = AX-SRV-03. 

 Set Database = BizTalkMgmtDb. 
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3. Enter Server Name and TCP/IP Port.  The server name refers to the Application Object Server 
(AOS) and the port refers to the port being used by the AOS. The port is usually set to 2712. You 
can look at the Microsoft Dynamics AX 2009 Server Configuration utility to obtain the server 
name and TCP/IP port. For more information, see Server and Database Administration Guide. 

Enter values for the following fields and click Next. 

 Set Server name = AX-SRV-03. 

 Set TCP/IP Port = 2712. 

 

4. Expand PurchaseRequisitionService and check read: async response as shown in the 

following screen shot.  

 

5. Click Finish.  

Note: This is a one-way send from AIF to BizTalk Server. Therefore, the read request operation is 
not required. 

http://www.microsoft.com/downloads/details.aspx?FamilyId=E7BFB7A8-EB99-4171-B75A-D9A37067BC19&displaylang=en
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6. Your project will now look like the following screen shot with the newly added BizTalk 
Orchestration.odx and the PurchaseRequisitionService_PurchaseRequistion.xsd files.  

7. Right-click BizTalk Orchestration.odx and rename it to PO.odx. Double-click PO.odx. Select 
Orchestration View. Right-click Orchestration Properties and select Properties Window. In 

the Typename field, enter ―PO‖ as shown in the following screen shot. 
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Add shapes to the orchestration. 

1. Open PO.odx. Using the Toolbox, add the following shapes. 

1. Receive 

2. Message Assignment 

3. Send 

 

2. Select Orchestration View.  Expand Types, then Multi-part Message Types, then 

PurchaseRequisitionService_read_Response. Right-click ReturnValue and select Properties 
Window. In the Properties window, confirm that the Type field defaults to 
DocProject.PurchaseRequisitionService_PurchaseRequisition.  

Create messages and set properties 

In this section, you will create two messages and set their properties. You can refer to the 

diagrams of screen shots in the preceding section for visual navigation. 
 

1. On the Orchestration View tab, right-click Messages and select New Message. Set the 
message properties as follows: 

 Set Identifier = Message_POInToBts. 

 To set MessageType, expand Multi- part Message Types, the select 

DocProject.PurchaseRequisitionService_read_Response from the list. 

2. Create the second message and set properties as follows: 

 Set Identifier = Message_POOutToFile. 

 To set Message Type, expand Schemas, then select 
DocProject.PurchaseRequisitionService_PurchaseRequisition from the list. 
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Configure shapes 

This section provides instructions to configure the shapes that we added earlier to the orchestration. 
You can refer to the diagrams of screen shots in the preceding section for visual navigation. 

1. Click shape Receive_1 and set properties as follows. 

 Set Activate = Select True from the list. 

 Set Message = Message_POInToBts. 

2. Click Shape ConstructMessage_1  and set properties as follows. 

1. To set Messages Constructed, select Message_POOutToFile from the list. Make sure you 
set this property before using the code in the next step to avoid getting syntax errors.  

2. Double-click MessageAssignment_1 within the shape and copy or type the following code 

into the BizTalk Expression Editor: 

Message_POOutToFile = Message_POInToBts.ReturnValue;  

3. Click shape Send_1 and set properties as follows: 

 Set Message = Message_POOutToFile. 

Configure operations for the shapes 

In this section, we will configure operations for the shapes in our orchestration. This section provides 
only relevant diagrams of screen shots. You can refer to the diagrams of screen shots in the preceding 
section for detailed visual navigation. 

Configure operations for shape Receive_1 

1. Click the exclamation icon on the shape Receive_1. Click the dialog box to create a new port.  

2. Click Next in the Welcome to the Port Configuration Wizard window.  

3. Set Name = Port_POInToBts and click Next. 
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4. Select Use an existing Port Type. Set the Port Type to 
DocProject.PurchaseRequisitionService_AsyncResponse. Click Next. 

 
5. In the following wizard page, leave the Port binding set to Specify later.  The wizard will 

automatically set the binding when it connects the receive shape to this new port. Click Next.  

 

6. Click Finish in the Port Configuration Wizard window.  

7. At this message, click OK. 
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8. Port and shape relationship should look like the following screen shot.  

Configure operations for shape Send_1 

1. Click the exclamation icon for shape Send_1. Click the dialog box to create a new port.  

2. Click Next on the Welcome to the Port Configuration Wizard window.  

3. Set the Name to Port_POOutBtsToFile as shown in the following screen shot and click Next. 
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4. In the Select a Port Type window: 

1. Select Create a new Port Type. 

2. Set Port Type Name = PortType_POOutBtsToFile. 

3. Click Next. 

 

5. Click Next. 
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6. Click Finish in the Port Configuration Wizard window.  

7. At this message, click OK. 

8. Port and shape relationship should look like the following screen shot. 

9. Save the project at this point. 

Create a strong name key 

You will need to create and assign a strong name key to compile the project.  

1. Start a command prompt and navigate to C:\Program Files\Microsoft Visual Studio 
8\SDK\v2.0\Bin.  

2. Type sn –k “c:\TestKey.snk”. Make sure you get a message that your key pair was written as 
shown in the following screen shot. 
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Build and deploy the Visual Studio project 

We are now ready to build the Visual Studio project and deploy it to the BizTalk Server. 

1. In Visual Studio 2005 navigate to Project > DocProject Properties. 

2. Expand Common Properties and click Assembly. Locate Assembly Key File. Navigate to the 

location of the strong name key file that was created in the preceding section and select the file. 
You should see the strong name key file as shown in the following screen shot. 
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3. Expand Configuration Properties and click Deployment. Set the following property values: 

 Set Server = AX-SRV-03. 

 Set Application Name = DocProject. The value you set in this field will be used as the 
BizTalk application.  

4. Click Apply and then click OK. 

 

5. Right-click DocProject in the Solution Explorer pane.  

1. Click Deploy. 

2. Check the status bar to confirm that the deployment is successful. 
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Configure orchestration in BizTalk Server 

This section provides instructions to configure the asynchronous and synchronous orchestrations in 
BizTalk Server administration console. To begin: 

1. Launch the BizTalk Server 2006 Administration Console. If the administrative console is 
already launched, you need to right-click the BizTalk group and click Refresh. 

2. Navigate to DocProject by expanding parent nodes as shown in the following screen shot. Right-

click DocProject and select Configure. 
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Configure the asynchronous orchestration (Async.odx) 

1. Click Async. This is the Async.odx orchestration in the Visual Studio 2005 project.  

2. In the Host field, select BizTalk Server Application from the list. 

 

Configure receive port Port_AsyncXmlIn 

1. Click <None> in the Port_AsyncXmlIn field and select <New Receive Port…> from the list. 
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2. In the Receive Port Properties  window, set the Name to ReceivePort1_AsyncXmlIn and then 
click Receive Locations. 

3. In the Receive Locations pane, click New. 
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4. Set properties as follows: 

1. Set Name = ReceiveLocation1_AsyncXmlIn. 

2. Set Type = File (from the list) and click Configure.  

 
3. In the File Transport Properties window, click Browse.  
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4. Create a new folder that will be used as the receive folder. Name the folder TestIn. Select 
TestIn and click OK. 

 

5. Click OK to continue. 
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5. Set Receive pipeline to XMLReceive, click Apply and then click OK. 

 

6. Click OK. 
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Configure receive port Port_AsyncDynToBts 

1. In the Configure Application window, click <None> in the receive ports field for 
Port_AsyncDynToBts and select New Receive Port. 

 
2. In the Receive Port Properties window, set Name to ReceivePort1_AsyncDyntoBts. Click 

Receive Locations. 
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3. In the Receive Locations window, click New.  

4. In the Receive Location Properties window, set the properties as follows.  

 Set Name = ReceiveLocation1_AsyncDynToBts. 

 Set Type = Microsoft Dynamics AX 2009 (from the list) and then click Configure. 
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5. In the Microsoft Dynamics AX 2009 Transport Properties window, set the property values as 
follows: 

 Set Authentication Type = Select Proxy User from the list. 

 Set Gateway User = contoso\administrator. 

 Set Proxy User = contoso\administrator. 

 Set Proxy User Password = Password of the proxy user (pass@word1). 

 Set AOS Port = 2712. 

 Set AOS Server = AX-SRV-03. 

 Click Apply and then click OK. 
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6. In the Receive Location Properties window, click Apply and then click OK. 

 
7. Click OK.  
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Configure send port Port_AsyncBtsToDyn 

1. In the Configure Application window, click <None> in Port_AsyncBtsToDyn field as shown in 
the following screen shot. Then select < New Send Port…> from the list. 

2. In the Send Port Properties window, set property values as follows: 

 Set Name = SendPort1_AsyncBtsToDyn. 

 Set Type = Microsoft Dynamics AX 2009 (from the list). 

 Click Configure. 

 

  



 

 

83 
 

CONFIGURING THE APPLICATION INTEGRATION FRAMEWORK (AIF) BIZTALK ADAPTER FOR DATA EXCHANGE 
 

3. In the Microsoft Dynamics AX 2009 Transport Properties window, set the following property 
values:  

 Set Authentication Type = Select Proxy User from the list. 

 Set Gateway User = contoso\administrator. 

 Set Proxy User = contoso\administrator. 

 Set Proxy User Password = Password of the proxy user (pass@word1). 

 Set AOS Port = 2712. 

 Set AOS Server = AX-SRV-03. 

 Click Apply and then click OK. 
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4. In the Send Port Properties window, click Apply and then click OK. 

Configure send port Port_AsyncXmlOut. 

1. In the Configure Application window, click <None> in the Port_AsyncXmlOut field as shown 
in the following screen shot. Select <New Send Port… > from the list. 
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2. In the Send Port Properties window, set property values as follows: 

 Set Name = SendPort1_AsyncXmlOut. 

 To set Type, select File from the list and then click Configure.  Create and select a folder 
called C:\TestOut.  

 To set Send Pipeline, select XMLTransmit (from the list). 

3. Click Apply and then click OK. 

 
4. Make sure your screen looks like the following screen shot. Click Apply, then click OK.  
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Enable the receive locations for asynchronous orchestration. 

Click the Receive Locations node in the BizTalk Server 2006 Administration Console. Select 
both the locations, right-click and select Enable.  

Start the send ports for asynchronous orchestration.  

Click the Send Ports node. Select both the send Ports. Right-click. Select Start.  
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Start the asynchronous orchestration.  

Select the Orchestrations node. Right-click DocProject.Async and then select Start. 

 

Restart the host instances.  

Select Platform Settings > Host Instances. Right-click BiztalkServerApplication and select 
Restart. 
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Configure synchronous orchestration (Sync.odx) 

This section provides step-by-step instructions to configure the orchestration that creates a sales 
order in the synchronous mode. You can configure all your orchestrations together instead of 
configuring one orchestration at a time. However, this document configures each orchestration 
separately for ease of learning. To begin: 

1. Launch the BizTalk Server 2006 Administration Console. If the administrative console is 
already launched, you need to right-click the BizTalk group and click Refresh. 

2. Navigate to DocProject by expanding parent nodes as shown in the following screen shot. Right-

click DocProject and select Configure. 
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3. Set property values as follows: 

 Select Sync from orchestrations list. 

 Set Host to BizTalk Server Application. 

Configure receive port Port_SyncXmlIn. 

1. Click <None> in the Port_SyncXmlIn field as shown in the following screen shot. Select <New 
Receive Port…> from the list.  
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2. In the Receive Port Properties window, set the Name field to ReceivePort1_SyncXmlIn and 
then click Receive Locations.  

 
3. In the Receive Locations window, click New. 
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4. In the Receive Location Properties window, set property values as follows: 

 Set Name = ReceiveLocation1_SyncXmlIn. 

 Set Type = File. Click Configure. Create and select a new folder called C:\TestIn2.  

 Set Receive Pipeline = XMLReceive (from the list). 

5. Click Apply and then click OK.  

 
6. Click OK to return to Configure Application window.  
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Configure send port Port_Sync 

1. Click <None> in the Port_Sync field as shown in the following screen shot. Select <New Send 
Port…> from the list.  

    

2. In the Send Port Properties window, set the property values as follows:  

 Set Name = SendPort1_Sync 

  Set Type = Microsoft Dynamics 2009. Click Configure. 
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3. In the Microsoft Dynamics AX 2009 Transport Properties window, set the following property 
values:  

 Set Authentication Type = Select Proxy User from the list. 

 Set Gateway User = contoso\administrator. 

 Set Proxy User = contoso\administrator. 

 Set Proxy User Password = Password of the proxy user (pass@word1). 

 Set AOS Port = 2712. 

 Set AOS Server = AX-SRV-03. 

4. Click Apply and then click OK. 
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5. In the Send Port Properties window, click Apply and then click OK. 

 

Configure send port Port_SyncXmlOut 

1. Click <None> in the Port_SyncXmlOut field as shown in the following screen shot. Select 
<New Send Port…> from the list. 
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2. In the Send Port Properties window, set property values as follows: 

 Set Name = SendPort1_SyncXmlOut. 

 To set Type, select File from the list. Click Configure to select folder C:\TestOut. This folder 
was created during the configuration of the asynchronous orchestration. You will not need to 

create the folder. 

 Set Send Pipeline =  XMLTransmit (from the list). 

 Click Apply and then click OK. 

 

3. Make sure the Configure Application window looks like the following screen shot. Click Apply 
and then click OK.  
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Enable receive locations for synchronous orchestration.  

Click the Receive Locations node in the BizTalk Server 2006 Administration Console. Right-click 
Receive Location1_SyncXmlIn and then select Enable. 

 

Start send ports for synchronous orchestration. 

Click the Send Ports node. Select SendPort1_sync and SendPort1_SyncXmlOut. Right-click and 
select Start. 
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Start the synchronous orchestration. 

 Click the Orchestrations node. Select DocProject.Sync. Right-click and select Start. 

Restart the host instances.  

Select Platform Settings > Host Instances. Right-click BiztalkServerApplication and select 
Restart. 
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Configure asynchronous orchestration for purchase order (PO.odx) 

This section provides step-by-step instructions to configure the orchestration that sends the purchase 
order from AIF to BizTalk Server in asynchronous mode. Note that it is technically possible for you to 
configure all your orchestration at the same time. This document provides steps to configure each 
orchestration separately for ease of use and learning. To begin: 

1. Launch BizTalk Server 2006 Administration Console.  

2. Navigate to Console Root > BizTalk Server 2006 Administration > BizTalk Group > Applications > 
DocProject. Right-click DocProject and select Configure.  

3. Set property values as follows: 

 Select PO from orchestrations list. 

 Set Host to BizTalk Server Application. 
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Configure receive port Port_POInToBts. 

Click <None> in the Port_POInToBts field as shown in the following screen shot. Select 
ReceivePort1_AsyncDynToBts from the list.  

Configure send port Port_POOutBtsToFile.  

1. Click <None> in the Port_POOutBtsToFile field as shown in the following screen shot.. Select 
<New Send Port…> from the list. 
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2. In the Send Port Properties window, set property values as follows: 

 Set Name = SendPort1_POOutBtsToFile. 

 To set Type, select File from the list. Click Configure to select folder C:\TestOut. We created 
this folder when we set up the asynchronous configuration. You will not need to create the 

folder. 

 Set Send Pipeline = XMLTransmit (from the list). 

 Click Apply and then click OK. 

3. Make sure the Configure Application window looks like the following diagram. Click Apply and 
then click OK. 
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Enable receive locations for asynchronous orchestration. 

Click the Receive Locations node in the BizTalk Server 2006 Administration Console. Confirm 
that all the receive locations are enabled as shown in the following screen shot. We are re-using 

ReveiveLocation1_AsyncDynToBts for this orchestration. Therefore, there is no change in the 
receive location.  

Start send ports for synchronous orchestration.  

Click the Send Ports node. Right-click SendPort1_POOutBtsToFile and select Start.  
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Start the synchronous orchestration.  

Click the Orchestrations node. Right-click DocProject.PO and select Start.  

 

Restart the host instances. Select Platform Settings > Host Instances. Right-click 
BiztalkServerApplication and select Restart. 
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Configure AIF batch jobs and tasks 

This section provides step-by-step instructions to configure an AIF batch job and batch tasks. For 
more information on batch jobs and batch tasks, see Microsoft Dynamics AX 2009 Implementation 
Guide. 

Configure the batch job 

1. Launch the Microsoft Dynamics AX Windows client. 

2. Navigate to Basic > Inquiries > Batch job. 

3. Create a new record. 

4. Set the Job Description field to AIF. 

5. Save the form. 

 

Configure batch tasks 

On the Batch jobs forms, click View Tasks to open the Batch tasks form. Add four records in the 
Batch Tasks form and set property values as shown in the following steps.  

1. Insert a new record and set values for the following fields. 

 Set Task Description = in 1. 

 Set Company accounts = CEU (from the list). 

 Set Class Name = AifGatewayReceiveService (from the list). 

2. Save the form.  

3. Insert a new record and set values for the following fields. 

 Set Task Description = in 2. 

 Set Company accounts = CEU (from the list). 

 Set Class Name = AifInboundProcessingService (from the list). 

4. Save the form.  

5. Insert a new record and set values for the following fields. 

http://go.microsoft.com/fwlink/?LinkId=124789
http://go.microsoft.com/fwlink/?LinkId=124789
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 Set Task Description = out 1. 

 Set Company accounts = CEU (from the list). 

 Set Class Name = AifOutboundProcessingService (from the list). 

6. Save the form.  

7. Insert a new record and set values for the following fields. 

 Set Task Description = out 2. 

 Set Company accounts = CEU (from the list). 

 Set Class Name = AifGatewaySendService (from the list). 

8. Save and close the form, which should resemble the following screen shot. 

9. Close the Batch tasks Form. 

Configure the recurrence schedule 

On the Batch job form, click the Recurrence button. Set Count to one (1) minute to process the 
jobs faster.  You need to be careful in setting the recurrence count in a production environment. 
Depending on the number of the messages processed, size of the messages, and frequency of 

recurrence, batch jobs may impact the overall performance of your production environment. Click OK. 
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Configure the job status 

1. On the Batch jobs form, click the record containing the AIF job. Click the Functions button and 
then select Change status.  

2. In the Select New Status window, click Waiting.  

 
The batch tasks will run every minute. 
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Test the asynchronous orchestration 

This section provides instruction to create a process and test the sales order using the asynchronous 
orchestration. 

Create an XML document for the asynchronous test 

The following sample XML file contains the data of the sales order to be created in 
Microsoft Dynamics AX. There is no endpoint or action information in this XML file—that information is 
added to the message in the BizTalk orchestration. The test data used for synchronous and 
asynchronous tests is identical except for the quantity. The XML document for the asynchronous test 
has a quantity value of 1111.  

 
<SalesOrder xmlns="http://schemas.microsoft.com/dynamics/2008/01/documents/SalesOrder"> 

        <DocPurpose>Original</DocPurpose> 

<SalesTable class="entity"> 

          <CurrencyCode>USD</CurrencyCode> 

          <CustAccount>1101</CustAccount> 

          <DeliveryDate>2008-10-11</DeliveryDate> 

          <Payment>N030</Payment> 

          <PurchOrderFormNum>PO</PurchOrderFormNum> 

          <SalesLine class="entity"> 

            <ItemId>1000</ItemId> 

            <SalesQty>1111</SalesQty> 

     <SalesUnit>ea</SalesUnit> 

  <InventDim class="entity"> 

   <configId>HD</configId> 

   <InventColorId>01</InventColorId> 

   <InventSizeId>42</InventSizeId> 

  </InventDim> 

  <MarkupTransLine class="entity"> 

   <MarkupCode>01</MarkupCode> 

  </MarkupTransLine>  

   </SalesLine> 

         <MarkupTransHeader class='entity'> 

   <MarkupCode>01</MarkupCode> 

  </MarkupTransHeader> 

    </SalesTable> 

</SalesOrder> 
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The following screen shot shows a preview of the sample XML file in Internet Explorer. 

 

Process the sales order in asynchronous mode 

Copy the XML file to folder C:\TestIn. This is the folder that we have configured for the asynchronous 

orchestration. BizTalk Server will monitor the folder and will pick up the file. When you refresh the 
folder C:\TestIn, you should see nothing in it.  

Test the creation of a sales order and the return value 

AIF processes the incoming XML from BizTalk Server and creates a sales order based on information 

received. AIF then returns an entity key (sales order number) to BizTalk Server in an XML document. 
BizTalk Server places the XML document in the outbound folder C:\TestOut. You can use the XML file 
in the outbound folder and the Microsoft Dynamics AX application to validate the test results as 
follows: 

1. Verify that BizTalk has sent the request and received the sales order number by checking 
C:\TestOut folder. We have configured C:\TestOut as the outbound folder for both the 
synchronous and the asynchronous orchestrations. You should see an XML document with a name 

such as {E3999436-2CB8-4BE2-BFCB-30085776256F}.xml. This XML document provides the sales 
order ID of the new sales order as shown in the following screen shot.  
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2. In the Microsoft Dynamics AX application, navigate to Accounts receivable > Common Forms 
> Sales Order Details. Confirm that the sales order is processed in the Microsoft Dynamics AX 
application as shown in the following screen shot. Note that customer, item, and quantity details 
match the XML file that we sent via BizTalk. 

 

3. If the sales order is not created, check your configuration settings and the troubleshooting section 
in this document. 
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Test the synchronous orchestration 

This section provides instruction to create a process and test the sales order using the asynchronous 
orchestration. 

Create an XML document for the synchronous test 

The following sample XML file contains the data of the sales order to be created in 
Microsoft Dynamics AX. There is no endpoint or action information in this XML file—that information is 
added to the message in the BizTalk orchestration. The test data used for synchronous and 
asynchronous tests is identical except for the quantity. The XML document for the synchronous test 
has a quantity value of 2222 

<SalesOrder xmlns="http://schemas.microsoft.com/dynamics/2008/01/documents/SalesOrder"> 

        <DocPurpose>Original</DocPurpose> 

<SalesTable class="entity"> 

          <CurrencyCode>USD</CurrencyCode> 

          <CustAccount>1101</CustAccount> 

          <DeliveryDate>2008-10-11</DeliveryDate> 

          <Payment>N030</Payment> 

          <PurchOrderFormNum>PO</PurchOrderFormNum> 

          <SalesLine class="entity"> 

            <ItemId>1000</ItemId> 

            <SalesQty>2222</SalesQty> 

     <SalesUnit>ea</SalesUnit> 

  <InventDim class="entity"> 

   <configId>HD</configId> 

   <InventColorId>01</InventColorId> 

   <InventSizeId>42</InventSizeId> 

  </InventDim> 

  <MarkupTransLine class="entity"> 

   <MarkupCode>01</MarkupCode> 

  </MarkupTransLine>  

   </SalesLine> 

         <MarkupTransHeader class='entity'> 

   <MarkupCode>01</MarkupCode> 

  </MarkupTransHeader> 

    </SalesTable> 

</SalesOrder> 

Process the sales order in the synchronous mode 

Copy the XML file to folder C:\TestIn2. This is the folder that we have configured for the synchronous 

orchestration. BizTalk Server will monitor the folder and will pick up the file. When you refresh the 
folder, you should see nothing in it.  

Test the creation of the sales order and the return value 

AIF processes the incoming XML from BizTalk Server, creates a sales order, and provides a response 

synchronously. In the response document, AIF returns an entity key (sales order number) to BizTalk 
Server. BizTalk Server places the XML document in the outbound folder C:\TestOut. You can use the 
XML file in the outbound folder and Microsoft Dynamics AX application to validate the test results as 
follows: 
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1. Verify that BizTalk has sent the request and received the sales order number by checking 
―C:\TestOut‖ folder. We have configured ―C:\TestOut‖ as the outbound folder for both the 
synchronous and the asynchronous orchestrations. You should see an XML document with a name 
such as {E3999436-2CB8-4BE2-BFCB-30085776256F}.xml. This XML document provides the sales 

order ID of the new sales order as shown in the following screen shot.  

2. In the Microsoft Dynamics AX application, navigate to Accounts receivable > Common Forms 
> Sales Order Details. Confirm that the sales order is processed in the Microsoft Dynamics AX 
application as shown in the following screen shot. Note that customer, item, and quantity details 
match the XML file that we sent via BizTalk. 

 

3. If the sales order is not created, check your configuration settings and check the troubleshooting 

section in this document. 
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Test the orchestration to send purchase orders 

This section provides instruction to test the electronic transmission of the purchase order from AIF to 
BizTalk Server.  

Post an open purchase order 

This section provides instructions for posting an open purchase order and then sending the 

purchase order electronically via AIF. 

 
1. Launch the Microsoft Dynamics AX Windows client. Click Accounts payable > Places > 

Purchase Orders to launch the purchase order list page. 

2. In the purchase order list page, select any purchase order with a status of Open order. In this 
case, we will use purchase order 000403. Double-click on purchase order 000403 to open the 
Purchase order form. 
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3. Click the Posting button and then click Purchase order. This will launch the Posting purchase 
order form as shown in the next step. 

4. In the Quantity field, select All from the list. Click OK. This will launch the Purchase order form 
with purchase order 000403 as shown in the next step. 
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5. Click Inquiries and then Purchase order.  

6. Click Send electronically and then select Original. You can either select Original or Copy from 
the popup menu to send either the original or copy of the purchase order as an XML document.   
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Test the “send” of the purchase order from AIF to BizTalk Server.  

You can use the XML that BizTalk places in the outbound folder to validate the receipt of the purchase 
order as follows: 

1. Verify that BizTalk has sent the purchase order by checking the C:\TestOut folder. We have 
configured C:\TestOut as the outbound folder for the orchestration that sends the purchase order. 
You should see an XML document with a name such as {E3999436-2CB8-4BE2-BFCB-
30085776256F}.xml.  

2. Open the purchase order document in Internet Explorer. Verify that information you received is 

same as the information for purchase order 000403 in the Microsoft Dynamics AX application.  

3. If you do not receive the purchase order within a short time, check your configuration settings and 
see the troubleshooting section in this document. If you set the recurrence to one minute, the 
processing should take about 2–5 minutes depending upon the response time of your test 
environment.   
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Troubleshooting 

If you get an error message, check your configuration settings in Microsoft Dynamics AX, BizTalk 
Server, and the Visual Studio project. Also check the XML schema of your document and make sure all 
the required fields are included. This section provides information on additional tools that you can use 
to troubleshoot error messages. 

Microsoft Dynamics AX application 

Errors might typically result from an invalid XML schema or improper settings of the AIF configuration. 
You can use the following tools to determine the source of the error. 

1. Check the AIF Queue manager form. To launch the form select Basic > Periodic > Application 
Integration Framework > Queue manager. Use this form to view messages (both inbound and 

outbound) in the Microsoft Dynamics AX queues for asynchronous document exchanges that use 

adapters.  

2. You can use the View Document Log form to export a message that has an error, edit the 
document to fix the error, and then click Import message on the Queue manager form to 
resubmit the updated document to the queue for processing.  

For more information, see the following topics in the Server and Database Administration Help:  

 Configure endpoint action policies  

 Configure a channel  

 Configure an endpoint manager form 

3. Check the AIF Exceptions form. To launch the form, select Basic > Periodic > Application 
Integration Framework > Exceptions. Use this form to view exceptions including processing 
errors, warnings, and informational messages that are related to document exchanges and other 
AIF events..  

For more information, see "The error log and queue management" in the Server and Database 
Administration Guide.  

 

http://go.microsoft.com/fwlink/?LinkID=99628
http://go.microsoft.com/fwlink/?LinkID=99628
http://go.microsoft.com/fwlink/?LinkID=99628
http://go.microsoft.com/fwlink/?LinkID=99628
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4. Check the  AIF Document history form. To launch the form, select Basic > Periodic > 
Application Integration Framework > Document history. Use this form to track the history 
of documents that are transferred. To save copies of the XML code for these documents, click 
Document logs.  For more information, see the topic "Viewing the document log" in the Server 

and Database Administration Guide.  

 

BizTalk Server and Visual Studio 

Launch the Windows Event Viewer and check the Application and System logs to view error 
messages from BizTalk Server. Check the configuration settings in the Visual Studio application and 
BizTalk Server Administration Console. For more information on specific error messages, refer to the 

system documentation for these products.  

  

http://go.microsoft.com/fwlink/?LinkID=99628
http://go.microsoft.com/fwlink/?LinkID=99628
http://go.microsoft.com/fwlink/?LinkID=99628


 

 

117 
 

CONFIGURING THE APPLICATION INTEGRATION FRAMEWORK (AIF) BIZTALK ADAPTER FOR DATA EXCHANGE 
 

 
Microsoft Dynamics is a line of integrated, adaptable business management solutions that enables you 
and your people to make business decisions with greater confidence. Microsoft Dynamics works like 

and with familiar Microsoft software, automating and streamlining financial, customer relationship and 
supply chain processes in a way that helps you drive business success. 

 

U.S. and Canada Toll Free 1-888-477-7989 

Worldwide +1-701-281-6500 

www.microsoft.com/dynamics 

 

This document is for informational purposes only. MICROSOFT MAKES NO WARRANTIES, EXPRESS, 

IMPLIED, OR STATUTORY, AS TO THE INFORMATION IN THIS DOCUMENT. 

Information in this document, including URL and other Internet Web site references, is subject to 
change without notice. The entire risk of the use or the results from the use of this document remains 
with the user. Unless otherwise noted, the companies, organizations, products, domain names, e-mail 
addresses, logos, people, places, and events depicted in examples herein are fictitious. No association 

with any real company, organization, product, domain name, e-mail address, logo, person, place, or 
event is intended or should be inferred. 

Complying with all applicable copyright laws is the responsibility of the user. Without limiting the 
rights under copyright, no part of this document may be reproduced, stored in or introduced into a 
retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, 
recording, or otherwise), or for any purpose, without the express written permission of Microsoft 
Corporation.  

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property 
rights covering subject matter in this document. Except as expressly provided in any written license 

agreement from Microsoft, the furnishing of this document does not give you any license to these 
patents, trademarks, copyrights, or other intellectual property. 

 

© 2008 Microsoft Corporation. All rights reserved. 

Microsoft, Active Directory, BizTalk, IntelliSense, Internet Explorer, MSDN, Visual Studio, Windows, 

Windows Server, Windows Vista and the Microsoft Dynamics Logo are either registered trademarks or 
trademarks of Microsoft Corporation in the United States and/or other countries. Other product and 
company names mentioned herein may be the trademarks of their respective owners. 

 

 

 

 
 
 
 
 

 


